Forum

Sluggish Starting t...
 
Notifications
Clear all

Sluggish Starting then Top Open Light Blinks On  

  RSS

Tom O5
(@tom-o5)
Active Member
Joined: 4 months ago
Posts: 7
18/11/2020 10:57 am  

For a couple years now, especially when it's cold, my MX-5 is sluggish starting. The starting cranks a little then hesitates and starts. Almost like my old ,69 Triumph Spitfire. The starter motor would struggle then start. Once that happens and the car is running, the top open (PRT) light starts blinking. I have to drive a bit; stop; shut it off, and then turn it back on for the light to go out. Not so much concerned about the light but about the starting. Any ideas?

Tom O5


Quote
Flying Dutchman
(@flying-dutchman)
LVMOC Treasurer Admin
Joined: 1 year ago
Posts: 159
18/11/2020 1:52 pm  

Have you had the battery checked with a resistance grid, Tom?  Doing a load check will let you know if it's close to expiring.  Low voltage can cause things like the top open indicator light to misbehave.

Silver 2011 NC PRHT Grand Touring (actually Janice's car)


ReplyQuote
Triviawayne
(@triviawayne)
Trusted Member
Joined: 6 months ago
Posts: 83
18/11/2020 3:12 pm  

I don't know why, but my NC loves to get corrosion around the battery terminals, and before I knew about this, it made the car do some wacky things electrically.

After that incident, I would take a wire brush to the terminals every month.  Then I found a spray that keeps the corrosion away, sprayed the terminals months ago and haven't had to use the wire brush at all.


ReplyQuote
CTt3MX5
(@ctt3mx5)
Estimable Member
Joined: 1 year ago
Posts: 111
18/11/2020 8:18 pm  

Agreed with the above, have the battery tested.  By chance do you know how oid it is?

2016 ST GT aka Ghost


ReplyQuote
Tom O5
(@tom-o5)
Active Member
Joined: 4 months ago
Posts: 7
24/11/2020 12:09 pm  

Thanks, everyone; will give it all a look.


ReplyQuote
Share: